Issue
Custom domain does not work with Elementor hosting.
Possible cause
Your custom domain may not work with your Elementor hosted website for the following reasons:
- The connection process is not completed.
- Settings not defined correctly in the domain provider’s settings.
- Settings not defined correctly in the Elementor hosted website dashboard.
Solution
Try the following procedures, in the following order, until you solve the issue that can occur when adding a custom domain to Elementor hosting.
Verify that your domain has successfully propagated with the correct records
Check that the domain you are trying to connect holds the correct DNS records to work with Elementor Hosting and is pointing to your site. Follow these steps:
- Verify your records. Use any domain propagation checker to do this. For example, dnschecker.org.
- A records addresses should match one of these addresses:
- * 162.159.168.9
- * 162.159.137.9
- If a different address or multiple addresses other than the ones described in Step 2 show up in one or more locations, adjust your DNS records to remove those and add the ones described above.
If there are AAAA records pointing to the root (@) or any Parked domains, remove them too.
Info: If you’re not sure what to modify, go to Check DNS settings. - Enter your domain name with the prefix www and look for CNAME records. The result address should show your website’s default domain. For example, myverycoolsite.elementor.cloud.
If a different address shows up in one or more locations, adjust your DNS records and add the correct address.
Info: If you’re not sure what to modify, go to Check DNS settings. - After adjusting the records, wait for them to propagate. This can take up to 72 hours.
- Check your website. Try to reach your website using the domain and see if the issue is solved.
If the issue is not solved, continue with the following steps.
Restart the connection process on my.elementor.com
- Login to My Elementor dashboard.
- Go to Websites.
- Locate your website card and hover over it.
- Click Manage This Website.
- Under the Manage Domains section, look for the domain you’ve added. If available, click the trash can icon to remove the domain.
- Click Connect My Domain or the plus icon to restart the connection process.
Check DNS settings
Check your DNS settings at your domain registrar’s website and modify conflicting records, if any. Follow these steps:
- Follow the on-screen instructions to finish setting up your domain. Copy the following information:
- A RECORD
- CNAME
- Log in to your domain provider account and look for your DNS records.
Refer to your domain registrar’s documentation for locating their DNS tools.- Verify and add your A records – Add one of the following records as indicated in the on-screen instructions on my.elementor:
- Type: A Host: @ Value: 162.159.137.9
- Type: A Host: @ Value: 162.159.138.9
- Remove conflicting records:
- Remove Parked domain records.
- Remove any A or AAAA records that point the root domain (“@”) to a different address. For details, see What are AAAA records?
- Verify and add your CNAME record
- Add the following record as indicated in the on-screen instructions on my.elementor:
- Type: CNAME
- Host: www
- Value: <sitename>.elementor.cloud
- Check the CNAME record in dnschecker.org
Note: If your domain is hosted at Cloudflare, you cannot turn on Proxy as this will not allow the domain to be properly connected. It needs to be set to DNS Only.
- Add the following record as indicated in the on-screen instructions on my.elementor:
- Verify and add your A records – Add one of the following records as indicated in the on-screen instructions on my.elementor:
- Save the records and wait for the DNS changes to propagate. For details, see What is DNS propagation?
- Go back to the Elementor website dashboard and follow the on-screen instructions to finish setting up your domain. If the popup has closed, click Connect My Domain to reopen it.
Check if you can reach your website using the domain
Enter your domain’s address in any browser to try reaching your website. You can try using incognito mode to avoid caching issues.
If the issue persists, submit a ticket to Elementor support.