help center

Search
Close this search box.
On this page

Empty template library issue

Last Update: February 21, 2024

Issue

Users do not see any templates in the Pages/Blocks on clicking Add Template.

Empty template library 2

Possible causes

This issue can occur due to the following causes:

  • Low wordpress memory limit
  • Permission issues

Solution

To troubleshoot, follow these steps:

  1. Login to WP Admin. 
  2. Go to Elementor > Tools.
    Empty template library 3
  3. Click Sync Library.
  4. On your WordPress Dashboard, go to Elementor > System Info.
  5. Under WordPress Environment, check the Memory limit allocated to WordPress. 
    Empty template library 1
    If your memory limit is under 256MB (40MB for instance), ask your hosting company to increase it. For details, refer Editing wp-config.php.
  6. Check for permission issue. Ask your hosting company to check the error logs of your server.
  7. Ask your hosting company if the allow_url_fopen function is active.
Note
You can test Elementor on a localhost to confirm if the error is due to server issue.

Have more questions? We’re more than happy to assist.

Link is copied to clipboard!
On this page

Is this article helpful?

Share this article

Stuck?
Our Elementor Expert is Ready

Book a 45-min video consultation call with an Elementor expert and elevate your site!