Issue
The following license mismatch error can occur when you try to activate your license:
“Your license key does not match your current domain. This is most likely due to a change in the domain URL of your site (including HTTPS/SSL migration). Please deactivate the license and then reactivate it again.”
Possible cause
This error can occur under the following conditions:
- Your site and WordPress domains (URL) do not match. This usually occurs after changes to your domain or SSL.
- When the domain listed in your My Elementor account does not match the domain you are trying to activate Elementor Pro from.
Example: In your My Elementor account dashboard, your Elementor Pro plugin is activated for the site mysite.com. You try to activate your Elementor Pro plugin from the dashboard of my-site.com. In this case, you will receive a license mismatch error.
Solution
In most cases, deactivating and reactivating your license solves the issue. Follow the below procedures stepwise to resolve the issue:
Verify WordPress URL and Site URL.
- Login to WP Admin.
- Go to Settings > General.
- Make sure the WordPress Address (URL) matches the Site Address (URL) exactly. To be sure, copy the site address and paste it into the WordPress address.
Disconnect the Elementor Pro license from the site.
- Go to Elementor > License.
- Click Disconnect. This disconnects your license from the website.
Deactivate the website in your My Elementor account.
- Login to your My Elementor dashboard.
- For the required website click on the three dots. A menu pops up.
- Select View related subscription. A page with subscription details opens.
- Click the deactivate icon.
Connect and activate your Elementor Pro license.
- Go to WP Admin.
- Go to Elementor > License.
- Click Connect & Activate.
- Confirm that the information is correct and click Activate. Your license should be activated.
If you’re still experiencing difficulties, submit a ticket for assistance.