How To Fix The Package Could Not Be Installed Error

If trying to install Elementor and get the following error “The package could not be installed. PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature” it may be due to limited resources, or a bad Zip file. It may also occur when trying to install from the WP repository. The most likely causes of this error are:

  1. The .zip file you’re trying to install does not use the correct file structure for a WP plugin
  2. The .zip file is extremely large and you’re hitting memory limits while trying to unzip it
  3. You don’t have enough server space left on your web hosting account to install the plugin

The third option is the most likely. To confirm this, try to upload another large file to your site (example: a large image or video file). If you’re not able to upload large files, then storage space is likely the issue. To correct this, log in to your hosting account and check how much unused space you have. If you are at or near your maximum, you’ll either need to delete some files (perhaps you have unused themes or plugins, or old backups or log files that are no longer needed), or upgrade to an account with a larger amount of storage.

Share it on social networks

Share on facebook
Share on twitter
Share on linkedin
Share on email
Was this article helpful?

Get Started With Elementor Today

Join millions of professionals who use Elementor to build WordPress websites faster and better than ever before