My Site Is Working With WordPress 2.6, Will Elementor Work For Me?

No. 

Elementor supports WordPress 4.4 or greater, and is compatible with PHP 5.4 or greater.

Share it on social networks

Share on facebook
Share on twitter
Share on linkedin
Share on email

Did this answer your question?

255 people find it useful

Yes

No

Get Started With Elementor Today

Join millions of professionals who use Elementor to build WordPress websites faster and better than ever before