Issue
Elementor prompts to upgrade to Elementor Pro even after buying the subscription.
Possible causes
Following may cause the system to prompt you to upgrade to Elementor Pro even after buying the subscription:
- Using old version of Elementor and Elementor Pro
- License key not activated
- Plugin conflicts
Solutions
Update your Elementor/Elementor Pro
Make sure you are using the latest versions of both Elementor and Elementor Pro.
- Login to Wp Admin.
- Go to Dashboard > Updates. The WordPress Updates page opens.
- Click the Check again link. You will receive notification for new updates, if any.
Activate your license
Remember that both the free version and the Pro version must be installed and activated.
- Confirm that you have activated your license key under Elementor > License in your WordPress dashboard.
- You can also login to the Websites section of your My Elementor dashboard. Then, enter a new URL if yours is not listed.
Resolve plugin conflict
Check for a plugin conflict, as this is often the problem.
Follow these steps to check for plugin conflict:
- Temporarily deactivate all of your plugins except Elementor and Elementor Pro. If the Go Pro message disappears, then you know one of the disabled plugins is causing the problem.
- Reactivate each plugin, one at a time, until the problem reappears. The last plugin reactivated is the cause of the problem.
- Contact the 3rd party plugin’s developers to get help with resolving the conflict, or use a different plugin with similar functionality.