help center

Search
Close this search box.
On this page

Troubleshooting Elementor after changing domains/URL

Last Update: March 30, 2025

Issue

Elementor does not work after the URL is changed when migrating the website.

Possible cause

Migration can cause the WordPress Address (URL) to be different from the Site Address (URL). This can prevent Elementor from working properly.

Solution

When you change the domain name/URL of your site, you need to replace all references to your old site URL with your new URL. This should be done before using Elementor Tools to edit the Elementor settings.

Change the home and siteurl fields using a DB management program

  1. After you have copied your site files to your new site, access the files using a MySQL management tool such as phpMyAdmin. 
    image 19 Troubleshooting Elementor after changing domains/URL 1
  2. Locate the wp-options table.
    Note
    wp-options is the most common name for this table that contains this information, but the table will always include the work options.

    image 20 Troubleshooting Elementor after changing domains/URL 3
  3. Locate the home and siteurl options.
    image 21 Troubleshooting Elementor after changing domains/URL 5
  4. For each option, click the option value field.
    image 22 Troubleshooting Elementor after changing domains/URL 7
  5. Enter your new domain/URL.

Change the home and site URL with a text editor

Instead of using a MySQL tool, you can manually update the wp-config file.

To update the wp-config file

  1. Open the wp-config.php file with a text editor.
    image 23 Troubleshooting Elementor after changing domains/URL 9
    This lets you edit the file.
    image 24 Troubleshooting Elementor after changing domains/URL 11
  2. Look for two lines that define home and siteurl (replace myoldurl.com with your previous URL.)
  3. Replace your previous URL with your new one.
    image 25 Troubleshooting Elementor after changing domains/URL 13
  4. Save the file.

Search your entire database for instances of the old URL

Most sites contain numerous references to the site’s URL. The best way to replace these references is with a ׳Search and Replace׳ plugin. For more information about installing plugins, see WordPress plugins

Use Elementor tools to replace Elementor content

If your website is still encountering issues after replacing the URL, you may need to use Elementor tools to update Elementor content. See below to see how to update Elementor content.

  1. Login to WP Admin.
    1 Elementor tools 1 Troubleshooting Elementor after changing domains/URL 15
  2. Go to Elementor > Tools.
    Click the Replace URL tab Troubleshooting Elementor after changing domains/URL 17
  3. Click Replace URL.
    Replace the URL Troubleshooting Elementor after changing domains/URL 19
  4. Under Update Site Address (URL), enter the old url and new url.
    Click Replace URL Troubleshooting Elementor after changing domains/URL 21
  5. Click Replace URL.
    Clear the general tab Troubleshooting Elementor after changing domains/URL 23
  6. Click the General tab.
    click clear files Troubleshooting Elementor after changing domains/URL 25
  7. Click Clear Files & Data.
    Click save changes 2 Troubleshooting Elementor after changing domains/URL 27
  8. Click Save Changes.
    Note
    This process only affects Elementor-related pages.

Verify the URLs

Follow the below steps:

  1. Go to the WordPress Dashboard.
  2. Click Settings. The General Settings page opens.
    URL change disrupts Elementor functioning 2
  3. Check WordPress Address (URL) and Site Address (URL). They should be same.
Note
Make sure you assign the license to the new URL from My Elementor.
Important
Adding an SSL Certificate to your website (HTTP to HTTPS) also requires you to replace the URL. For details, see I Added An SSL Certificate To My Website And Now I Cannot Edit » Elementor.

Have more questions? We’re more than happy to assist.

Link is copied to clipboard!
On this page

Is this article helpful?

Share this article