Issue
Elementor does not work after the URL is changed when migrating the website.
Possible cause
Migration can cause the WordPress Address (URL) to be different from the Site Address (URL). This can cause elementor to not work.
Solution
Replace and regenerate URL
Follow these steps:
- Login to Wp Admin
- Go to Elementor > Tools.
- Click Replace URL.
- Under Update Site Address (URL), enter the old url and new url.
- Click Replace URL.
- Go to General.
- Click Regenerate Files & Data.
- Click Save Changes.
Verify the URLs
Follow the below steps:
- Go to the WordPress Dashboard.
- Click Settings. The General Settings page opens.
- Check WordPress Address (URL) and Site Address (URL). They should be same.
Note
Make sure you assign the license to the new URL from My Elementor.
Important
Adding an SSL Certificate to your website (HTTP to HTTPS) also requires you to replace the URL. For details, see I Added An SSL Certificate To My Website And Now I Cannot Edit » Elementor.