Issue
Elementor does not work after the URL is changed when migrating the website.
One common issue caused by a URL mismatch is that custom fonts do not appear on the frontend.
Possible cause
Migration can cause the WordPress Address (URL) to be different from the Site Address (URL). This can cause Elementor to not work.
Solution
Replace and regenerate URL
Follow these steps:
- From WP Admin, navigate to Elementor>Editor.

- In the left panel, click Tools.

- Click the Replace URL tab.

- Under Update Site Address (URL), enter the old url and new url.

- Click the Replace URL button.

- Click the General tab.

- Click Clear Files & Data.

- Click Save Changes.

Verify the URLs
Follow the below steps:
- From WP Admin, navigate to Settings.

This opens the General Settings screen.
Check WordPress Address (URL) andSite Address (URL). They should be same.
Note
Make sure you assign the license to the new URL from My Elementor.
Important
Adding an SSL Certificate to your website (HTTP to HTTPS) also requires you to replace the URL. For details, see I Added An SSL Certificate To My Website And Now I Cannot Edit » Elementor.